Make IT Now

Website Outage
Resolved·Partial outage

The issue affecting Make It Now has been fully resolved.
All systems are operating normally.

We sincerely apologize for the inconvenience and appreciate your understanding.

Sat, Feb 14, 2026, 08:21 AM
(4 hours ago)
·
Affected components
Website
Updates

Resolved

The issue affecting Make It Now has been fully resolved.
All systems are operating normally.

We sincerely apologize for the inconvenience and appreciate your understanding.

Sat, Feb 14, 2026, 08:21 AM

Monitoring

A fix has been implemented, and we are currently monitoring the system to ensure stability.

We appreciate your patience and will provide a final update once the issue is fully resolved.

Sat, Feb 14, 2026, 08:21 AM

Identified

We have identified the root cause of the issue affecting Make It Now.
Our team is implementing a fix and working to restore full functionality as quickly as possible.

We will continue to provide updates until the issue is fully resolved.

Sat, Feb 14, 2026, 08:20 AM

Investigating

We are currently investigating an issue affecting some users of Make It Now.
Our team is actively working to identify the root cause.
We will share an update as soon as more information becomes available.

Thank you for your patience.

Sat, Feb 14, 2026, 08:20 AM